Exchange 12 and MMC 3.0

I’m staying in a hotel in London all this week delivering part of the Exchange 12 ignite roadshow. We’re delivering 2 sets of Exchange 12 training to partners in the UK. There are 7 Microsoft UK gurus from different parts of the business (Consulting Services, Support, Technical specialists and me) delivering a couple of modules each. I got the easy bits of the Modules: Installing Exchange (setup switches, server roles etc.) with a lab at the end to install E12 onto the virtual machines, and in the other module, I talk about how reporting will work with E12 – so I get to talk about MOM and how it will be used to monitor E12 when Exchange is released. (Have a look at the Monad scripts from the scripting centre for more info by the way…)

The only problems that I’ve actually encountered with the install of this beta can occur with the installation of MMC 3.0. (Thanks Jon for reminding me about this). If you install E12 from your MSDN or TechNet subscription, you’ll be directed to the Microsoft site to install MMC 3.0. (You need to .Net framework 2.0 too). It’s a really good idea to make sure that all of your MMC windows are closed before you install this by the way – to avoid any issues with the Exchange install, or to avoid any unnecessary reboots. However, sometimes the E12 install won’t actually realise that the MMC 3.0 has actually been installed, and won’t let you continue with the E12 install. If you get this issue, you’ll be going around in circles wondering why things aren’t working and talking (swearing) at your machine a lot…

So what you need to do is follow the steps that Nino has blogged about in the Exchange blog… and that will sort you out..